Well, I’m not a frequent user of the package, but when it comes to semantics, the choice for setBody as opposed to addRawPostData is obvious: a HTTP body isn’t limited to a POST request, also PUT requests may contain a body, so the method was incorrectly named. Perhaps that’s the reason they have renamed it?

PHP has a long standing tradition of using “odd” names for stuff like this anyway: consider the $_GET superglobal, which isn’t restricted to GET requests at all, and $_POST is readable when using a PUT request too. Better names would’ve been $_QUERY and $_BODY, but hey, that’s just nitpicking ;)