I published some benchmarks when PHP 7 was new (see https://lornajane.net/posts/2015/php-7-benchmarks) and agree that everyone should update - also PHP 5 is no longer supported so PHP 7 is the best option in any case.