This is a common question. At one time there was a plan for PHP 6 and books published about it and everything - then we changed tack and some of that work became PHP 5.3 (this is why there is such a big gap between the PHP 5.2 and PHP 5.3 release dates). When we were ready for the next new version, we felt it was confusing to have a completely different version 6.0 so it was bumped to 7.0.