Or, if you need something like an LXD/LXC container with PHP self contained on the container, this is still a great strategy. Especially when you're dealing with WordPress client sites which want to run a plugin that doesn't support PHP 7.x yet.

Thanks for sharing Lornajane!