Sorry, I haven't used the github API again since - although maybe I should look into it. I think the older APIs are still supported though, so perhaps you could try those?