The problem is that PHP moves on much faster than the distros. We support two PHP versions at a time, with a year of security fixes to the outgoing one when a new version is released. If LTS versions are released more than 2.5 years apart approximately, then you'll have either not-LTS distro or not-supported PHP at some point.